Main Page

The Imaging Source Ansi Wrapper DLL Documentation

3.2

Please see "tisgrabber.h" for the function documentation.

Generated on Fri Jan 27 17:05:24 2012 for The Imaging Source Ansi Wrapper DLL by doxygen 1.2.14 written by Dimitri van Heesch, © 1997-2002


File Index

The Imaging Source Ansi Wrapper DLL File List

Here is a list of all files with brief descriptions:
tisgrabber.h
Generated on Fri Jan 27 17:05:24 2012 for The Imaging Source Ansi Wrapper DLL by doxygen 1.2.14 written by Dimitri van Heesch, © 1997-2002


tisgrabber.h File Reference

#include "TISGrabberGlobalDefs.h"

Data Structures

struct | HGRABBER_t__

Defines

#define | AC __stdcall
__stdcall for Borland C and Ansi C. More...

#define | NOHWNDDEFINED 1
#define | __HWND int
Workaround if we are in non windows environment. More...

#define | HGRABBER HGRABBER_t*
Type of grabber object handle. Used for all functions. More...

#define | IC_SUCCESS 1
Return value for success. More...

#define | IC_ERROR 0
Return value that indicates an error. More...

#define | IC_NO_HANDLE -1
No device handle. HGRABBER is NULL. More...

#define | IC_NO_DEVICE -2
No device opened, but HGRABBER is valid. More...

#define | IC_NOT_AVAILABLE -3
Property not avaiable, but HGRABBER is valid. More...

#define | IC_NO_PROPERTYSET -3
The Propertyset was not queried. More...

#define | IC_DEFAULT_WINDOW_SIZE_SET -3
The live display window size could not be set. More...

#define | IC_NOT_IN_LIVEMODE -3
A device has been opened, but is is not in live mode. More...

#define | IC_PROPERTY_ITEM_NOT_AVAILABLE -4
A requested property item is not available. More...

#define | IC_PROPERTY_ELEMENT_NOT_AVAILABLE -5
A requested element of a given property item is not available. More...

#define | IC_PROPERTY_ELEMENT_WRONG_INTERFACE -6
A requested element has not the interface, which is needed. More...

Typedefs

typedef HGRABBER_t__ | HGRABBER_t
Internal structure of the grabber object handle. More...

typedef void(* | FRAME_READY_CALLBACK )(HGRABBER hGrabber, unsigned char *pData, unsigned long frameNumber, void *)
typedef void(* | DEVICE_LOST_CALLBACK )(HGRABBER hGrabber, void *)

Functions

int AC | IC_InitLibrary (char *szLicenseKey)
Initialize the library. More...

HGRABBER AC | IC_CreateGrabber ()
Create a new grabber handle. More...

void AC | IC_ReleaseGrabber (HGRABBER *hGrabber)
Releas an HGRABBER object. More...

void AC | IC_CloseLibrary ()
Closes the library, cleans up memory. More...

int AC | IC_OpenVideoCaptureDevice (HGRABBER hGrabber, char *szDeviceName)
Opens a video capture device. More...

void AC | IC_CloseVideoCaptureDevice (HGRABBER hGrabber)
Closes a video capture device. More...

char *AC | IC_GetDeviceName (HGRABBER hGrabber)
Returns the name of the current video capture device. More...

int AC | IC_GetVideoFormatWidth (HGRABBER hGrabber)
Returns the width of the video format. More...

int AC | IC_GetVideoFormatHeight (HGRABBER hGrabber)
returns the height of the video format. More...

int AC | IC_SetFormat (HGRABBER hGrabber, COLORFORMAT format)
Sets the color format of the sink. More...

COLORFORMAT AC | IC_GetFormat (HGRABBER hGrabber)
Returns the current color format of the sink. More...

int AC | IC_SetVideoFormat (HGRABBER hGrabber, char *szFormat)
Sets the video format. More...

int AC | IC_SetVideoNorm (HGRABBER hGrabber, char *szNorm)
Set the video norm. More...

int AC | IC_SetInputChannel (HGRABBER hGrabber, char *szChannel)
Sets an input channel. More...

int AC | IC_StartLive (HGRABBER hGrabber, int iShow)
Starts the live video. More...

int AC | IC_PrepareLive (HGRABBER hGrabber, int iShow)
Prepare the grabber for starting the live video. More...

int AC | IC_SuspendLive (HGRABBER hGrabber)
Suspends an image stream and puts it into prepared state. More...

void AC | IC_StopLive (HGRABBER hGrabber)
Stops the live video. More...

int AC | IC_IsCameraPropertyAvailable (HGRABBER hGrabber, CAMERA_PROPERTY eProperty)
Check whether a camera property is available. More...

int AC | IC_SetCameraProperty (HGRABBER hGrabber, CAMERA_PROPERTY eProperty, long lValue)
Set a camera property. More...

int AC | IC_CameraPropertyGetRange (HGRABBER hGrabber, CAMERA_PROPERTY eProperty, long *lMin, long *lMax)
Get the minimum and maximum value of a camera property. More...

int AC | IC_GetCameraProperty (HGRABBER hGrabber, CAMERA_PROPERTY eProperty, long *lValue)
Get a camera property's value. More...

int AC | IC_EnableAutoCameraProperty (HGRABBER hGrabber, int iProperty, int iOnOff)
Enables or disables property automation. More...

int AC | IC_IsCameraPropertyAutoAvailable (HGRABBER hGrabber, CAMERA_PROPERTY iProperty)
Check whether automation for a camera property is available. More...

int AC | IC_GetAutoCameraProperty (HGRABBER hGrabber, int iProperty, int *iOnOff)
Retrieve whether automatic is enabled for the specifield camera property. More...

int AC | IC_IsVideoPropertyAvailable (HGRABBER hGrabber, VIDEO_PROPERTY eProperty)
Check whether the specified video property is available. More...

int AC | IC_VideoPropertyGetRange (HGRABBER hGrabber, VIDEO_PROPERTY eProperty, long *lMin, long *lMax)
Retrieve the lower and upper limit of a video property. More...

int AC | IC_GetVideoProperty (HGRABBER hGrabber, VIDEO_PROPERTY eProperty, long *lValue)
Retrieve the the current value of the specified video property. More...

int AC | IC_IsVideoPropertyAutoAvailable (HGRABBER hGrabber, VIDEO_PROPERTY eProperty)
Check whether the specified video property supports automation. More...

int AC | IC_GetAutoVideoProperty (HGRABBER hGrabber, int iProperty, int *iOnOff)
Get the automation state of a video property. More...

int AC | IC_SetVideoProperty (HGRABBER hGrabber, VIDEO_PROPERTY eProperty, long lValue)
Set a video property. More...

int AC | IC_EnableAutoVideoProperty (HGRABBER hGrabber, int iProperty, int iOnOff)
Switch automatition for a video property,. More...

int AC | IC_GetImageDescription (HGRABBER hGrabber, long *lWidth, long *lHeight, int *iBitsPerPixel, COLORFORMAT *format)
Retrieve the properties of the current video format and sink typ. More...

int AC | IC_SnapImage (HGRABBER hGrabber, int iTimeOutMillisek)
Snaps an image from the live stream. More...

int AC | IC_SaveImage (HGRABBER hGrabber, char *szFileName, IMG_FILETYPE ft, long quality)
Saves an image to a file. More...

unsigned char *AC | IC_GetImagePtr (HGRABBER hGrabber)
Retuns a pointer to the image data. More...

int AC | IC_SetHWnd (HGRABBER hGrabber, __HWND hWnd)
Sets a window handle for live display. More...

void AC | IC_GetSerialNumber (HGRABBER hGrabber, char *szSerial)
Return the video capture device's serial number. More...

int AC | IC_ListDevices (char *szDeviceList, int iSize)
Count and list devices. More...

int AC | IC_ListVideoFormats (HGRABBER hGrabber, char *szFormatList, int iSize)
List available video formats. More...

int AC | IC_GetDeviceCount ()
Get the number of the currently available devices. More...

char *AC | IC_GetDevice (int iIndex)
Get the name of a video capture device. More...

char *AC | IC_GetUniqueNamefromList (int iIndex)
Get the unique name of a video capture device. More...

int AC | IC_GetInputChannelCount (HGRABBER hGrabber)
Get the number of the available input channels. More...

char *AC | IC_GetInputChannel (HGRABBER hGrabber, int iIndex)
Get the name of an input channel. More...

int AC | IC_GetVideoNormCount (HGRABBER hGrabber)
Get the count of available video norms. More...

char *AC | IC_GetVideoNorm (HGRABBER hGrabber, int iIndex)
Get the name of a video norm. More...

int AC | IC_GetVideoFormatCount (HGRABBER hGrabber)
Returns the count of available video formats. More...

char *AC | IC_GetVideoFormat (HGRABBER hGrabber, int iIndex)
Return the name of a video format. More...

int AC | IC_SaveDeviceStateToFile (HGRABBER hGrabber, char *szFileName)
Save the state of a video capture device to a file. More...

HGRABBER AC | IC_LoadDeviceStateFromFile (HGRABBER hGrabber, char *szFileName)
Load a device settings file. More...

int AC | IC_SaveDeviceSettings (HGRABBER hGrabber, char *szFilename)
int AC | IC_OpenDeviceBySettings (HGRABBER hGrabber, char *szFilename)
int AC | IC_LoadDeviceSettings (HGRABBER hGrabber, char *szFilename)
int AC | IC_OpenDevByDisplayName (HGRABBER hGrabber, char *szDisplayname)
Open a video capture by using its DisplayName. More...

int AC | IC_GetDisplayName (HGRABBER hGrabber, char *szDisplayname, int iLen)
Get the display name of a device. More...

int AC | IC_OpenDevByUniqueName (HGRABBER hGrabber, char *szDisplayname)
int AC | IC_GetUniqueName (HGRABBER hGrabber, char *szUniquename, int iLen)
Get a UniqueName from a currently open device. More...

int AC | IC_IsDevValid (HGRABBER hGrabber)
Returns whether a video capture device is valid. More...

int AC | IC_ShowPropertyDialog (HGRABBER hGrabber)
Show the VCDProperty dialog. More...

HGRABBER AC | IC_ShowDeviceSelectionDialog (HGRABBER hGrabber)
Show the device selection dialog. More...

int AC | IC_IsTriggerAvailable (HGRABBER hGrabber)
Check for external trigger support. More...

int AC | IC_EnableTrigger (HGRABBER hGrabber, int iEnable)
Enable or disable the external trigger. More...

void AC | IC_EnableOverlay (HGRABBER hGrabber, int iEnable)
Enable or disable the overlay bitmap. More...

long AC | IC_BeginPaint (HGRABBER hGrabber)
BeginPaint returns an HDC for GDI painting purposes. More...

void AC | IC_EndPaint (HGRABBER hGrabber)
End painting functions on the overlay bitmap. More...

void AC | IC_MsgBox (char *szText, char *szTitle)
Display a windows messagebox. More...

int AC | IC_SetFrameReadyCallback (HGRABBER hGrabber, FRAME_READY_CALLBACK cb, void *x1_argument_in_void_userdata)
int AC | IC_SetCallbacks (HGRABBER hGrabber, FRAME_READY_CALLBACK cb, void *x1_argument_in_void_userdata, DEVICE_LOST_CALLBACK dlCB, void *x2_argument_in_void_userdata)
int AC | IC_SetContinuousMode (HGRABBER hGrabber, int cont)
Set Continuous mode. More...

int AC | IC_SignalDetected (HGRABBER hGrabber)
Detects whether a video signal is available. More...

int AC | IC_GetTriggerModes (HGRABBER hGrabber, char *szModeList, int iSize)
Get trigger modes. More...

int AC | IC_SetTriggerMode (HGRABBER hGrabber, char *szMode)
Set the trigger mode. More...

int AC | IC_SetTriggerPolarity (HGRABBER hGrabber, int iPolarity)
Set the trigger polarity. More...

int AC | IC_GetExpRegValRange (HGRABBER hGrabber, long *lMin, long *lMax)
Retrieve exposure register values lower and upper limits. More...

int AC | IC_GetExpRegVal (HGRABBER hGrabber, long *lValue)
Retrieve the current register value of exposure. More...

int AC | IC_SetExpRegVal (HGRABBER hGrabber, long lValue)
Set a register value for exposure. More...

int AC | IC_EnableExpRegValAuto (HGRABBER hGrabber, int iOnOff)
Enable or disable automatic of exposure. More...

int AC | IC_GetExpRegValAuto (HGRABBER hGrabber, int *iOnOff)
Check whether automatic exposure is enabled. More...

int AC | IC_IsExpAbsValAvailable (HGRABBER hGrabber)
int AC | IC_GetExpAbsValRange (HGRABBER hGrabber, float *fMin, float *fMax)
int AC | IC_GetExpAbsVal (HGRABBER hGrabber, float *fValue)
int AC | IC_SetExpAbsVal (HGRABBER hGrabber, float fValue)
int AC | IC_GetColorEnhancement (HGRABBER hGrabber, int *OnOff)
int AC | IC_SetColorEnhancement (HGRABBER hGrabber, int OnOff)
int AC | IC_SoftwareTrigger (HGRABBER hGrabber)
int AC | IC_SetFrameRate (HGRABBER hGrabber, float FrameRate)
float AC | IC_GetFrameRate (HGRABBER hGrabber)
int AC | IC_SetWhiteBalanceAuto (HGRABBER hGrabber, int iOnOff)
int AC | IC_SetWhiteBalanceRed (HGRABBER hGrabber, long Value)
int AC | IC_SetWhiteBalanceGreen (HGRABBER hGrabber, long Value)
int AC | IC_SetWhiteBalanceBlue (HGRABBER hGrabber, long Value)
int AC | IC_FocusOnePush (HGRABBER hGrabber)
int AC | IC_ShowInternalPropertyPage (HGRABBER hGrabber)
int AC | IC_ResetProperties (HGRABBER hGrabber)
int AC | IC_ResetUSBCam (HGRABBER hGrabber)
int AC | IC_QueryPropertySet (HGRABBER hGrabber)
int AC | IC_SetDefaultWindowPosition (HGRABBER hGrabber, int Default)
int AC | IC_SetWindowPosition (HGRABBER hGrabber, int PosX, int PosY, int Width, int Height)
int AC | IC_IsPropertyAvailable (HGRABBER hGrabber, char *Property, char *Element)
int AC | IC_GetPropertyValueRange (HGRABBER hGrabber, char *Property, char *Element, int *Min, int *Max)
int AC | IC_GetPropertyValue (HGRABBER hGrabber, char *Property, char *Element, int *Value)
int AC | IC_SetPropertyValue (HGRABBER hGrabber, char *Property, char *Element, int Value)
int AC | IC_GetPropertyAbsoluteValueRange (HGRABBER hGrabber, char *Property, char *Element, float *Min, float *Max)
int AC | IC_GetPropertyAbsoluteValue (HGRABBER hGrabber, char *Property, char *Element, float *Value)
int AC | IC_SetPropertyAbsoluteValue (HGRABBER hGrabber, char *Property, char *Element, float Value)
int AC | IC_GetPropertySwitch (HGRABBER hGrabber, char *Property, char *Element, int *On)
int AC | IC_SetPropertySwitch (HGRABBER hGrabber, char *Property, char *Element, int On)
int AC | IC_PropertyOnePush (HGRABBER hGrabber, char *Property, char *Element)

Define Documentation

#define AC __stdcall

Calling convention of the DLL functions. For internal use only.

#define NOHWNDDEFINED 1

Workaround if we are in non windows environment.

#define __HWND int

#define HGRABBER HGRABBER_t*

The HGRABBER type is used to hold a handle to a grabber object. Each variable of HGRABBER type can contain one video capture device. It is possible to create more than one variables of this type: HGRABBER camera1 = IC_CreateGrabber(); HGRABBER camera2 = IC_CreateGrabber();

#define IC_SUCCESS 1

A return value of IC_SUCCESS indicates that a function has been performed without an error.

#define IC_ERROR 0

If a function returns IC_ERROR, then something went wrong.

#define IC_NO_HANDLE -1

This error indicates, that an HGRABBER handle has not been created yet. Please see IC_CreateGrabber() for creating an HGRABBER handle.

#define IC_NO_DEVICE -2

This return values indicates that no device has been opened. Please refer to IC_OpenVideoCaptureDevice().

#define IC_NOT_AVAILABLE -3

This return value indicates, that the video capture device is not in live mode, but live mode is for the current function call required. Please refer to IC_StartLive().

#define IC_NO_PROPERTYSET -3

This return value indicates, that the video capture device does not support the specified property.

#define IC_DEFAULT_WINDOW_SIZE_SET -3

This return value indicates, that the porperty set was not queried for the current grabber handle. Please check, whether IC_QueryPropertySet() was called once before using the function.

#define IC_NOT_IN_LIVEMODE -3

This return value indicates, that setting of a custom live display window size failed, because IC_SetDefaultWindowPosition() was not called with parameter false somewhere before.

See also:
IC_SetDefaultWindowPosition , IC_SetWindowPosition

#define IC_PROPERTY_ITEM_NOT_AVAILABLE -4

This return value indicates, that a device does not support the requested property, or the name of a property was written in wrong way.

See also:
IC_GetPropertyValueRange

#define IC_PROPERTY_ELEMENT_NOT_AVAILABLE -5

This return value indicates, that a device does not support the requested element property, or the name of an element was written in wrong way.

See also:
IC_GetPropertyValueRange

#define IC_PROPERTY_ELEMENT_WRONG_INTERFACE -6

This return value indicates, that a property element does not support the request, that is wanted. e.g. Exposure Auto has no range, therefore IC_GetPropertyValueRange(hGrabber, "Epxosure","Auto", &min, &max ) will return IC_PROPERTY_ELEMENT_WRONG_INTERFACE.

See also:
IC_GetPropertyValueRange

Typedef Documentation

typedef struct HGRABBER_t__ HGRABBER_t

This is the handle of an grabber object. Please use the HGRABBER type to access this object.

typedef void(* FRAME_READY_CALLBACK)(HGRABBER hGrabber, unsigned char* pData, unsigned long frameNumber, void* )

Type declaration for the frame ready callback function.

See also:
IC_SetFrameReadyCallback , IC_SetCallbacks

typedef void(* DEVICE_LOST_CALLBACK)(HGRABBER hGrabber, void* )

Type declaration for the device lost callback function.

See also:
IC_SetCallbacks

Function Documentation

int AC IC_InitLibrary ( char * szLicenseKey )

Initialize the ICImagingControl class library. This function must be called only once before any other functions of this library are called.

Parameters:
szLicenseKey IC Imaging Control license key or NULL if only a trial version is available.
Return values:
IC_SUCCESS | on success.
IC_ERROR | on wrong license key or other errors.
See also:
IC_CloseLibrary

HGRABBER AC IC_CreateGrabber ( )

Creates a new grabber handle and returns it. A new created grabber should be release with a call to IC_ReleaseGrabber if it is no longer needed.

Return values:
Nonzero | on success.
NULL | if an error occurred.
See also:
IC_ReleaseGrabber

void AC IC_ReleaseGrabber ( HGRABBER * hGrabber )

Release the grabber object. Must be called, if the calling application does no longer need the grabber.

Parameters:
hGrabber The handle to grabber to be released.
See also:
IC_CreateGrabber

void AC IC_CloseLibrary ( )

int AC IC_OpenVideoCaptureDevice | ( | HGRABBER | hGrabber,
 |  | char * | szDeviceName
 | ) |

Open a video capture device. The hGrabber handle must have been created previously by a call to IC_CreateGrabber(). Once a hGrabber handle has been created it can be recycled to open different video capture devices in sequence.

Parameters:
hGrabber | The handle to grabber object, that has been created by a call to IC_CreateGrabber
szDeviceName | Friendly name of the video capture device e.g. "DFK 21F04".
Return values:
IC_SUCCESS | on success.
IC_ERROR | on errors.
See also:
IC_CloseVideoCaptureDevice
    #include "tisgrabber.h"
    void main()
    {
        HGRABBER hGrabber;
        if( IC_InitLibrary(0) == IC_SUCCESS )
        {
            hGrabber = IC_CreateGrabber();
            if( hGrabber )
            {
                if( IC_OpenVideoCaptureDevice(hGrabber,"DFK 21F04") == IC_SUCCESS )
                {

                // .. do something with the video capture device.

                // Now clean up.
                IC_CloseVideoCaptureDevice( hGrabber );
                IC_ReleaseGrabber( hGrabber );
            }
            IC_CloseLibrary();
        }
    }

void AC IC_CloseVideoCaptureDevice ( HGRABBER hGrabber )

Close the current video capture device. The HGRABBER object will not be deleted. It can be used again for opening another video capture device.

Parameters:
hGrabber The handle to the grabber object.

char* AC IC_GetDeviceName ( HGRABBER hGrabber )

Retrieve the name of the current video capture device. If the device is invalid, NULL is returned.

Parameters:
hGrabber The handle to the grabber object.
Return values:
char | * The name of the video capture device
NULL | If no video capture device is currently opened.

int AC IC_GetVideoFormatWidth ( HGRABBER hGrabber )

int AC IC_GetVideoFormatHeight ( HGRABBER hGrabber )

int AC IC_SetFormat | ( | HGRABBER | hGrabber,
 |  | COLORFORMAT | format
 | ) |

Set the sink type. A sink type must be set before images can be snapped. The sink type basically describes the format of the buffer where the snapped images are stored.

Possible values for format are:

  • Y800
  • RGB24
  • RGB32
  • UYVY
The sink type may differ from the currently set video format.
Parameters:
hGrabber The handle to the grabber object.
format The desired color format. Possible values for format are:
  • Y800
  • RGB24
  • RGB32
  • UYVY
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
Note:
Please note that UYVY can only be used in conjunction with a UYVY video format.

COLORFORMAT AC IC_GetFormat ( HGRABBER hGrabber )

Retrieves the format of the sink type currently set (See IC_SetFormat() for possible formats). If no sink type is set or an error occurred, NONE is returned.

Parameters:
hGrabber The handle to the grabber object.
Returns:
The current sink color format.

int AC IC_SetVideoFormat | ( | HGRABBER | hGrabber,
 |  | char * | szFormat
 | ) |

Set a video format for the current video capture device. The video format must be supported by the current video capture device.

Parameters:
hGrabber | The handle to the grabber object.
szFormat | A string that contains the desired video format.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
    #include "tisgrabber.h"
    void main()
    {
        HGRABBER hGrabber;
        if( IC_InitLibrary(0) == IC_SUCCESS )
        {
            hGrabber = IC_CreateGrabber();
            if( hGrabber )
            {
                if( IC_OpenVideoCaptureDevice(hGrabber,"DFK 21F04") == IC_SUCCESS )
                {
                    if( IC_SetVideoFormat(hGrabber,"UYVY (640x480)" == IC_SUCCESS )
                    {
                        // .. do something with the video capture device.
                    }
                    // Now clean up.
                    IC_CloseVideoCaptureDevice( hGrabber );
                    IC_ReleaseGrabber( hGrabber );
                }
                IC_CloseLibrary();
            }
        }
    }

int AC IC_SetVideoNorm | ( | HGRABBER | hGrabber,
 |  | char * | szNorm
 | ) |

Set a video norm for the current video capture device.

Note:
The current video capture device must support video norms.
Parameters:
hGrabber | The handle to the grabber object.
szNorm | A string that contains the desired video format.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.

int AC IC_SetInputChannel | ( | HGRABBER | hGrabber,
 |  | char * | szChannel
 | ) |

Set a input channel for the current video capture device.

Note:
The current video capture device must support input channels..
Parameters:
hGrabber | The handle to the grabber object.
szChannel | A string that contains the desired video format.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.

int AC IC_StartLive | ( | HGRABBER | hGrabber,
 |  | int | iShow
 | ) |

Start the live video.

Parameters:
hGrabber The handle to the grabber object.
iShow The parameter indicates:
  • 1 : Show the video
  • 0 : Do not show the video, but deliver frames. (For callbacks etc.)
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
See also:
IC_StopLive

int AC IC_PrepareLive | ( | HGRABBER | hGrabber,
 |  | int | iShow
 | ) |

int AC IC_SuspendLive ( HGRABBER hGrabber )

void AC IC_StopLive ( HGRABBER hGrabber )

Stop the live video.

Parameters:
hGrabber The handle to the grabber object.
See also:
IC_StartLive

int AC IC_IsCameraPropertyAvailable | ( | HGRABBER | hGrabber,
 |  | CAMERA_PROPERTY | eProperty
 | ) |

int AC IC_SetCameraProperty | ( | HGRABBER | hGrabber,
 |  | CAMERA_PROPERTY | eProperty,
 |  | long | lValue
 | ) |

Set a camera property like exposure, zoom.

Parameters:
hGrabber | The handle to the grabber object.
eProperty The property to be set. It can have following values:
  • PROP_CAM_PAN
  • PROP_CAM_TILT,
  • PROP_CAM_ROLL,
  • PROP_CAM_ZOOM,
  • PROP_CAM_EXPOSURE,
  • PROP_CAM_IRIS,
  • PROP_CAM_FOCUS
lValue | The value the property is to be set to.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
Note:
lValue should be in the range of the specified property. If the value could not be set (out of range, auto is currently enabled), the function returns 0. On success, the functions returns 1.

int AC IC_CameraPropertyGetRange | ( | HGRABBER | hGrabber,
 |  | CAMERA_PROPERTY | eProperty,
 |  | long * | lMin,
 |  | long * | lMax
 | ) |

int AC IC_GetCameraProperty | ( | HGRABBER | hGrabber,
 |  | CAMERA_PROPERTY | eProperty,
 |  | long * | lValue
 | ) |

int AC IC_EnableAutoCameraProperty | ( | HGRABBER | hGrabber,
 |  | int | iProperty,
 |  | int | iOnOff
 | ) |

Enable or disable automatic for a camera property.

Parameters:
hGrabber The handle to the grabber object.
iProperty The property to be set. It can have following values:
  • PROP_CAM_PAN
  • PROP_CAM_TILT,
  • PROP_CAM_ROLL,
  • PROP_CAM_ZOOM,
  • PROP_CAM_EXPOSURE,
  • PROP_CAM_IRIS,
  • PROP_CAM_FOCUS
iOnOFF Enables or disables the automation. Possible values ar
  • 1 : Enable automatic
  • 0 : Disable Automatic
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
Note:
If the property is not supported by the current video capture device or automation of the property is not available with the current video capture device, the function returns 0. On success, the function returns 1.

int AC IC_IsCameraPropertyAutoAvailable | ( | HGRABBER | hGrabber,
 |  | CAMERA_PROPERTY | iProperty
 | ) |

int AC IC_GetAutoCameraProperty | ( | HGRABBER | hGrabber,
 |  | int | iProperty,
 |  | int * | iOnOff
 | ) |

int AC IC_IsVideoPropertyAvailable | ( | HGRABBER | hGrabber,
 |  | VIDEO_PROPERTY | eProperty
 | ) |

int AC IC_VideoPropertyGetRange | ( | HGRABBER | hGrabber,
 |  | VIDEO_PROPERTY | eProperty,
 |  | long * | lMin,
 |  | long * | lMax
 | ) |

int AC IC_GetVideoProperty | ( | HGRABBER | hGrabber,
 |  | VIDEO_PROPERTY | eProperty,
 |  | long * | lValue
 | ) |

int AC IC_IsVideoPropertyAutoAvailable | ( | HGRABBER | hGrabber,
 |  | VIDEO_PROPERTY | eProperty
 | ) |

int AC IC_GetAutoVideoProperty | ( | HGRABBER | hGrabber,
 |  | int | iProperty,
 |  | int * | iOnOff
 | ) |

int AC IC_SetVideoProperty | ( | HGRABBER | hGrabber,
 |  | VIDEO_PROPERTY | eProperty,
 |  | long | lValue
 | ) |

Set a video property like brightness, contrast.

Parameters:
hGrabber | The handle to the grabber object.
eProperty The property to be set. It can have following values:
  • PROP_VID_BRIGHTNESS ,
  • PROP_VID_CONTRAST,
  • PROP_VID_HUE,
  • PROP_VID_SATURATION,
  • PROP_VID_SHARPNESS,
  • PROP_VID_GAMMA,
  • PROP_VID_COLORENABLE,
  • PROP_VID_WHITEBALANCE,
  • PROP_VID_BLACKLIGHTCOMPENSATION,
  • PROP_VID_GAIN
lValue | The value the property is to be set to.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
Note:
lValue should be in the range of the specified property. If the value could not be set (out of range, auto is currently enabled), the function returns 0. On success, the functions returns 1.

int AC IC_EnableAutoVideoProperty | ( | HGRABBER | hGrabber,
 |  | int | iProperty,
 |  | int | iOnOff
 | ) |

Enable or disable automatic for a video propertery.

Parameters:
hGrabber The handle to the grabber object.
iProperty The property to be set. It can have following values:
  • PROP_VID_BRIGHTNESS,
  • PROP_VID_CONTRAST,
  • PROP_VID_HUE,
  • PROP_VID_SATURATION,
  • PROP_VID_SHARPNESS,
  • PROP_VID_GAMMA,
  • PROP_VID_COLORENABLE,
  • PROP_VID_WHITEBALANCE,
  • PROP_VID_BLACKLIGHTCOMPENSATION,
  • PROP_VID_GAIN
iOnOFF Enables or disables the automation. Possible values ar
  • 1 : Enable automatic
  • 0 : Disable Automatic
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.
Note:
If the property is not supported by the current video capture device or automation of the property is not available with the current video capture device, the function reurns 0. On success, the function returns 1.

int AC IC_GetImageDescription | ( | HGRABBER | hGrabber,
 |  | long * | lWidth,
 |  | long * | lHeight,
 |  | int * | iBitsPerPixel,
 |  | COLORFORMAT * | format
 | ) |

Retrieve the properties of the current video format and sink type

Parameters:
hGrabber | The handle to the grabber object.
lWidth | This recieves the width of the image buffer.
lHeight | This recieves the height of the image buffer.
iBitsPerPixel | This recieves the count of bits per pixel.
format | This recieves the current color format.
Return values:
IC_SUCCESS | on success
IC_ERROR | if something went wrong.

int AC IC_SnapImage | ( | HGRABBER | hGrabber,
 |  | int | iTimeOutMillisek
 | ) |

Snaps an image. The video capture device must be set to live mode and a sink type has to be set before this call. The format of the snapped images depend on the selected sink type.

Parameters:
hGrabber | The handle to the grabber object.
iTimeOutMillisek | The Timeout time is passed in milli seconds. A value of -1 indicates, that no time out is set.
Return values:
IC_SUCCESS | if an image has been snapped
IC_ERROR | if something went wrong.
IC_NOT_IN_LIVEMODE | if the live video has not been started.
See also:
IC_StartLive , IC_SetFormat

int AC IC_SaveImage | ( | HGRABBER | hGrabber,
 |  | char * | szFileName,
 |  | IMG_FILETYPE | ft,
 |  | long | quality
 | ) |

Save the contents of the last snapped image by IC_SnapImage into a file.

Parameters:
hGrabber | The handle to the grabber object.
szFileName | String containing the file name to be saved to.
ft File type if the image, It have be
  • FILETYPE_BMP for bitmap files
  • FILETYPE_JPEG for JPEG file.
quality | If the JPEG format is used, the image quality must be specified in a range from 0 to 100.
Return values:
IC_SUCCESS | if an image has been snapped
IC_ERROR | if something went wrong.
Remarks:
The format of the saved images depend on the sink type. If the sink type is set to Y800, the saved image will be an 8 Bit grayscale image. In any other case the saved image will be a 24 Bit RGB image.
Note:
IC Imaging Control 1.41 only supports FILETYPE_BMP.
See also:
IC_SnapImage , IC_SetFormat

unsigned char* AC IC_GetImagePtr ( HGRABBER hGrabber )

Retrieve a byte pointer to the image data (pixel data) of the last snapped image (see SnapImage()). If the function fails, the return value is NULL otherwise the value is a pointer to the first byte in the lowest image line (the image is saved bottom up!).

Parameters:
hGrabber The handle to the grabber object.
Return values:
Nonnull | Pointer to the image data
NULL | Indicates that an error occurred.
See also:
IC_SnapImage , IC_SetFormat

int AC IC_SetHWnd | ( | HGRABBER | hGrabber,
 |  | __HWND | hWnd
 | ) |

Assign an Window handle to display the video in.

Parameters:
hGrabber | The handle to the grabber object.
hWnd | The handle of the window where to display the live video in.
Return values:
IC_SUCCESS | if an image has been snapped
IC_ERROR | if something went wrong.

void AC IC_GetSerialNumber | ( | HGRABBER | hGrabber,
 |  | char * | szSerial
 | ) |

Return the serialnumber of the current device. Memory for the serialnumber must has been allocated by the application:

    char szSerial[20];
    GetSerialNumber( hGrabber, szSerial );

This function decodes the The Imaging Source serialnumbers.

Parameters:
hGrabber | The handle to the grabber object.
szSerial | char array that recieves the serial number.

int AC IC_ListDevices | ( | char * | szDeviceList,
 |  | int | iSize
 | ) |

Count all connected video capture devices. If the Parameter szDeviceList is NULL, only the number of devices is queried. The Parameter szDeviceList must be a two dimensional array of char. The iSize parameter specifies the length of the strings, that are used in the array.

Parameters:
szDeviceList | A two dimensional char array that recieves the list. Or NULL if only the count of devices is to be returned.
iSize | Not used.
Return values:
>= 0 Success, count of found devices
<0 An error occurred.
Simple sample to list the video capture devices:
    char szDeviceList[20][40];
    int iDeviceCount;

    iDeviceCount = IC_ListDevices( (char*)szDeviceList,40 );
    for( i = 0; i < iDeviceCount; i++ )
    {
        printf("%2d. %s\n",i+1,szDeviceList[i]);
    }

int AC IC_ListVideoFormats | ( | HGRABBER | hGrabber,
 |  | char * | szFormatList,
 |  | int | iSize
 | ) |

Count all available video formats. If the Parameter szFormatList is NULL, only the number of formats is queried. The Parameter szFormatList must be a two dimensional array of char. The iSize parameter specifies the length of the strings, that are used in the array to store the format names.

Parameters:
hGrabber | The handle to the grabber object.
szFormatList | A two dimensional char array that recieves the list. Or NULL if only the count of formats is to be returned.
Return values:
>= 0 Success, count of found video formats
<0 An error occurred.
Simple sample to list the video capture devices:
    char szFormatList[80][40];
    int iFormatCount;
    HGRABBER hGrabber;
    hGrabber = IC_CreateGrabber();
    IC_OpenVideoCaptureDevice(hGrabber, "DFK 21F04" );
    iFormatCount = IC_ListDevices(hGrabber, (char*)szFormatList,40 );
    for( i = 0; i < min( iFormatCount, 80); i++ )
    {
        printf("%2d. %s\n",i+1,szFormatList[i]);
    }
    IC_ReleaseGrabber( hGrabber );

int AC IC_GetDeviceCount ( )

Get the number of the currently available devices. This function creates an internal array of all connected video capture devices. With each call to this function, this array is rebuild. The name and the unique name can be retrieved from the internal array using the functions IC_GetDevice() and IC_GetUniqueNamefromList. They are usefull for retrieving device names for opening devices.

Return values:
>= 0 Success, count of found devices.
<0 An error occurred.
See also:
IC_GetDevice , IC_GetUniqueNamefromList

char* AC IC_GetDevice ( int iIndex )

Get a string representation of a device specified by iIndex. iIndex must be between 0 and IC_GetDeviceCount(). IC_GetDeviceCount() must have been called before this function, otherwise it will always fail.

Parameters:
iIndex The number of the device whose name is to be returned. It must be in the range from 0 to IC_GetDeviceCount(),
Returns:
Returns the string representation of the device on success, NULL otherwise.
See also:
IC_GetDeviceCount , IC_GetUniqueNamefromList

char* AC IC_GetUniqueNamefromList ( int iIndex )

Get unique device name of a device specified by iIndex. The unique device name consist from the device name and its serial number. It allows to differ between more then one device of the same type connected to the computer. The unique device name is passed to the function IC_OpenDevByUniqueName

Parameters:
iIndex The number of the device whose name is to be returned. It must be in the range from 0 to IC_GetDeviceCount(),
Returns:
Returns the string representation of the device on success, NULL otherwise.
See also:
IC_GetDeviceCount , IC_GetUniqueNamefromList , IC_OpenDevByUniqueName

int AC IC_GetInputChannelCount ( HGRABBER hGrabber )

Get the number of the available input channels for the current device. A video capture device must have been opened before this call.

Parameters:
hGrabber The handle to the grabber object.
Return values:
>= 0 Success
< 0 An error occured.
See also:
IC_GetInputChannel

char* AC IC_GetInputChannel | ( | HGRABBER | hGrabber,
 |  | int | iIndex
 | ) |

Get a string representation of the input channel specified by iIndex. iIndex must be between 0 and IC_GetInputChannelCount(). IC_GetInputChannelCount() must have been called before this function, otherwise it will always fail.

Parameters:
hGrabber | The handle to the grabber object.
iIndex | Number of the input channel to be used..
Return values:
Nonnull | The name of the specified input channel
NULL | An error occured.
See also:
IC_GetInputChannelCount

int AC IC_GetVideoNormCount ( HGRABBER hGrabber )

Get the number of the available video norms for the current device. A video capture device must have been opened before this call.

Parameters:
hGrabber The handle to the grabber object.
Return values:
>= 0 Success
< 0 An error occured.
See also:
IC_GetVideoNorm

char* AC IC_GetVideoNorm | ( | HGRABBER | hGrabber,
 |  | int | iIndex
 | ) |

Get a string representation of the video norm specified by iIndex. iIndex must be between 0 and IC_GetVideoNormCount(). IC_GetVideoNormCount() must have been called before this function, otherwise it will always fail.

Parameters:
hGrabber | The handle to the grabber object.
iIndex | Number of the video norm to be used.
Return values:
Nonnull | The name of the specified video norm.
NULL | An error occured.
See also:
IC_GetVideoNormCount

int AC IC_GetVideoFormatCount ( HGRABBER hGrabber )

Get the number of the available video formats for the current device. A video capture device must have been opened before this call.

Parameters:
hGrabber The handle to the grabber object.
Return values:
>= 0 Success
< 0 An error occured.
See also:
IC_GetVideoFormat

char* AC IC_GetVideoFormat | ( | HGRABBER | hGrabber,
 |  | int | iIndex
 | ) |

Get a string representation of the video format specified by iIndex. iIndex must be between 0 and IC_GetVideoFormatCount(). IC_GetVideoFormatCount() must have been called before this function, otherwise it will always fail.

Parameters:
hGrabber | The handle to the grabber object.
iIndex | Number of the video format to be used.
Return values:
Nonnull | The name of the specified video format.
NULL | An error occured.
See also:
IC_GetVideoFormatCount

int AC IC_SaveDeviceStateToFile | ( | HGRABBER | hGrabber,
 |  | char * | szFileName
 | ) |

Save the state of a video capture device to a file.

Parameters:
hGrabber | The handle to the grabber object.
szFileName | Name of the file where to save to.
Return values:
IC_SUCCESS | if an image has been snapped
IC_ERROR | if something went wrong.
See also:
IC_LoadDeviceStateFromFile

HGRABBER AC IC_LoadDeviceStateFromFile | ( | HGRABBER | hGrabber,
 |  | char * | szFileName
 | ) |

Load a device settings file. On success the device is opened automatically.

Parameters:
hGrabber | The handle to the grabber object. If it is NULL then a new HGRABBER handle is created. This should be released by a call to IC_ReleaseGrabber when it is no longer needed.
szFileName | Name of the file where to save to.
Returns:
HGRABBER The handle of the grabber object, that contains the new opened video capture device.
See also:
IC_SaveDeviceStateToFile , IC_ReleaseGrabber

int AC IC_SaveDeviceSettings | ( | HGRABBER | hGrabber,
 |  | char * | szFilename
 | ) |

Save the device settings to a file specified by szFilename. When used with IC Imaging Control 1.41 the device name, the input channel, the video norm and the video format are saved. When used with IC Imaging Control 2.0, the VCDProperties are saved as well. Returns 1 on success, 0 otherwise. Notice that in IC Imaging Control 1.41 the device name includes the trailing number if there is more than one device of the same type available. This can cause IC_OpenDeviceBySettings() to fail if one of those devices is unplugged. When used with IC Imaging Control 2.0, this cannot happen because the device name is stored without the trailing number. Instead the first device that matches the type specified in the settings file is opened.

Deprecated:
Use IC_SaveDeviceStateToFile instead.

int AC IC_OpenDeviceBySettings | ( | HGRABBER | hGrabber,
 |  | char * | szFilename
 | ) |

Open a device by a settings file specified by szFilename. If succedeed, 1 is returned and a device specified in the settings file is opened and initialized with the settings data. If failed, 0 is returned.

Deprecated:
Use IC_LoadDeviceStateFromFile instead.

int AC IC_LoadDeviceSettings | ( | HGRABBER | hGrabber,
 |  | char * | szFilename
 | ) |

Load device settings from a file specified by szFilename. A device must have been opened before this function is called. A check is performed whether the current device matches the device type stored in the settings file. If so, the settings are loaded and set. Returns 1 on success, 0 otherwise. Notice: This function will only work with IC Imaging Control 2.0. When used with IC Imaging Control 1.41, it will always return 0.

Deprecated:
Use IC_LoadDeviceStateFromFile instead.

int AC IC_OpenDevByDisplayName | ( | HGRABBER | hGrabber,
 |  | char * | szDisplayname
 | ) |

Open a video capture by using its DisplayName.

Parameters:
hGrabber | The handle to the grabber object.
szDisplayname | Displayname of the device. Can be retrieved by a call to IC_GetDisplayName().
Return values:
IC_SUCCESS | if an image has been snapped
IC_ERROR | if something went wrong.
See also:
IC_GetDisplayName

int AC IC_GetDisplayName | ( | HGRABBER | hGrabber,
 |  | char * | szDisplayname,
 |  | int | iLen
 | ) |

Get a DisplayName from a currently open device. The display name of a device can be another on different computer for the same video capture device.

Parameters:
hGrabber | Handle to a grabber object
szDisplayName | Memory that will take the display name. If it is NULL, the length of the display name will be returned.
iLen | Size in Bytes of the memory allocated by szDisplayName.
Return values:
IC_SUCCESS | On success. szDisplayName contains the display name of the device.
IC_ERROR | iLen is less than the length of the retrieved display name.
IC_NO_HANDLE | hGrabber is not a valid handle. GetGrabber was not called.
IC_NO_DEVICE | No device opened. Open a device, before this function can be used.
>1 | Length of the display name, if szDisplayName is NULL.
See also:
IC_OpenDevByDisplayName , IC_ReleaseGrabber

int AC IC_OpenDevByUniqueName | ( | HGRABBER | hGrabber,
 |  | char * | szDisplayname
 | ) |

Open a video capture by using its UniqueName. Use IC_GetUniqueName() to retrieve the unique name of a camera.

Parameters:
hGrabber | Handle to a grabber object
szDisplayName | Memory that will take the display name.
See also:
IC_GetUniqueName , IC_ReleaseGrabber

int AC IC_GetUniqueName | ( | HGRABBER | hGrabber,
 |  | char * | szUniquename,
 |  | int | iLen
 | ) |

Get a UniqueName from a currently open device.

Parameters:
hGrabber | Handle to a grabber object
szUniqueName | Memory that will take the Unique name. If it is NULL, the length of the Unique name will be returned.
iLen | Size in Bytes of the memory allocated by szUniqueName.
Return values:
IC_SUCCESS | On success. szUniqueName contains the Unique name of the device.
IC_ERROR | iLen is less than the length of the retrieved Unique name.
IC_NO_HANDLE | hGrabber is not a valid handle. GetGrabber was not called.
IC_NO_DEVICE | No device opened. Open a device, before this function can be used.
>1 | Length of the Unique name, if szUniqueName is NULL.

int AC IC_IsDevValid ( HGRABBER hGrabber )

This returns 1, if a valid device has been opened, otherwise it is 0.

Parameters:
hGrabber Handle to a grabber object.
Return values:
0 | There is no valid video capture device opened
1 | There is a valid video capture device openend.

int AC IC_ShowPropertyDialog ( HGRABBER hGrabber )

Show the VCDProperty dialog.

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | on success
IC_ERROR | on error.
Note:
This function will only work with IC Imaging Control 2.0 or higher. When used with IC Imaging Control 1.41, it will always return 0.

HGRABBER AC IC_ShowDeviceSelectionDialog ( HGRABBER hGrabber )

Show the device selection dialog. This dialogs enables to select the video capture device, the video norm, video format, input channel and frame rate.

Parameters:
hGrabber Handle to a grabber object.
Returns:
The passed hGrabber object or a new created if hGrabber was NULL.
    HGRABBER hTheGrabber;
    hTheGrabber = IC_ShowDeviceSelectionDialog( NULL );
    if( hTheGrabber != NULL )
    {
        IC_StartLive( hTheGrabber, 1 ); // Show the live video of this grabber
        IC_ShowPropertyDialog( hTheGrabber );   // Show the property page of this grabber
    }

int AC IC_IsTriggerAvailable ( HGRABBER hGrabber )

Return whether the current video capture device supports an external trigger.

Parameters:
hGrabber Handle to a grabber object.
Return values:
1 | An external trigger is supported
0 | No external trigger is supported.
See also:
IC_EnableTrigger

int AC IC_EnableTrigger | ( | HGRABBER | hGrabber,
 |  | int | iEnable
 | ) |

Enable or disable the external trigger.

Parameters:
hGrabber | Handle to a grabber object.
iEnable | 1 = enable the trigger, 0 = disable the trigger
Return values:
IC_SUCCESS | On success.
IC_ERROR | An error occurred.
See also:
IC_IsTriggerAvailable

void AC IC_EnableOverlay | ( | HGRABBER | hGrabber,
 |  | int | iEnable
 | ) |

Enable or disable the overlay bitmap on the live video

Parameters:
hGrabber | Handle to a grabber object.
iEnable | = 1 enables the overlay, 0 disables the overlay.

long AC IC_BeginPaint ( HGRABBER hGrabber )

BeginPaint returns an HDC for GDI painting purposes (like TextOut() etc.) When the paintings are finished, the function IC_EndPaint must be called.

Parameters:
hGrabber Handle to a grabber object.
Returns:
HDC The function returns not NULL, if the HDC could be retrieved. If the HDC could not be retrieved or an error has occured, the function returns 0.
Sample code:
    HDC hPaintDC;
    hPaintDC = IC_BeginPaint(hGrabber);
    if( hPaintDC != NULL )
    {
        TextOut( hPaintDC,10,10,"Text",4);
    }
    IC_EndPaint(hGrabber)

See also:
IC_EndPaint

void AC IC_EndPaint ( HGRABBER hGrabber )

The EndPaint functions must be called, after BeginPaint has been called, and the painting operations have been finished.

Parameters:
hGrabber Handle to a grabber object.
See also:
IC_BeginPaint

void AC IC_MsgBox | ( | char * | szText,
 |  | char * | szTitle
 | ) |

Display a windows messagebox.

Parameters:
szText | Message text
zsTitle | Title of the messagebox.

int AC IC_SetFrameReadyCallback | ( | HGRABBER | hGrabber,
 |  | FRAME_READY_CALLBACK | cb,
 |  | void * | x1_argument_in_void_userdata
 | ) |

Enable frame ready callback.

Parameters:
hGrabber | Handle to a grabber object.
cb | Callback function of type FRAME_READY_CALLBACK
x1_argument_in_void_userdata | Pointer to some userdata.
See also:
FRAME_READY_CALLBACK

int AC IC_SetCallbacks | ( | HGRABBER | hGrabber,
 |  | FRAME_READY_CALLBACK | cb,
 |  | void * | x1_argument_in_void_userdata,
 |  | DEVICE_LOST_CALLBACK | dlCB,
 |  | void * | x2_argument_in_void_userdata
 | ) |

Set callback function

Parameters:
hGrabber | Handle to a grabber object.
cb | Callback function of type FRAME_READY_CALLBACK, can be NULL, if no callback is needed
dlcb | Callback function of type DEVICE:LOST_CALLBACK, can be NULL, if no device lost handler is needed
x1_argument_in_void_userdata | Pointer to some userdata.
See also:
FRAME_READY_CALLBACK

int AC IC_SetContinuousMode | ( | HGRABBER | hGrabber,
 |  | int | cont
 | ) |

Set Continuous mode

In continuous mode, the callback is called for each frame, so that there is no need to use IC_SnapImage etc.

Parameters:
hGrabber | Handle to a grabber object.
cont | 0 : Snap continouos, 1 : do not automatically snap.
Remarks:
Not available in live mode.

int AC IC_SignalDetected ( HGRABBER hGrabber )

SignalDetected

Detects whether a video signal is available.

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | Signal detected
IC_ERROR | No video signal detected
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_NOT_IN_LIVEMODE | No live mode, startlive was not called

int AC IC_GetTriggerModes | ( | HGRABBER | hGrabber,
 |  | char * | szModeList,
 |  | int | iSize
 | ) |

Get trigger modes. Simple sample to list the video capture devices:

Parameters:
hGrabber | Handle to a grabber object.
szModeList | Twodimensional array of char that will recieve the mode list.
iSze | Size of the array (first dimension)
Return values:
0 | : No trigger modes available
>0 | : Count of available trigger modes
IC_ERROR | No video signal detected
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
    char szModes[20][10];
    int iModeCount;

    iModeCount = IC_GetTriggerModes(hGrabber, (char*)szModes,20);
    for( int i = 0; i < min( iModeCount, 20); i++ )
    {
        printf("%2d. %s\n",i+1,szModes[i]);
    }

int AC IC_SetTriggerMode | ( | HGRABBER | hGrabber,
 |  | char * | szMode
 | ) |

Set the trigger mode. Sets the mode that has been retrieved by a call to IC_GetTriggerModes.

Parameters:
hGrabber | Handle to a grabber object.
szMode | String containing the name of the mode.
Return values:
IC_SUCCESS | Success.
IC_ERROR | An error occurred
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_SetTriggerPolarity | ( | HGRABBER | hGrabber,
 |  | int | iPolarity
 | ) |

Set the trigger polarity

Sample:

    IC_SetTriggerPolarity(hGrabber, 0);
or
    IC_SetTriggerPolarity(hGrabber, 1);
Parameters:
hGrabber Handle to a grabber object.
iPolarity
  • 0 : Polarity on direction
  • 1 : Polarity the other direction
Return values:
0 | : No trigger polarity available
1 | : Count of available trigger modes
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_GetExpRegValRange | ( | HGRABBER | hGrabber,
 |  | long * | lMin,
 |  | long * | lMax
 | ) |

int AC IC_GetExpRegVal | ( | HGRABBER | hGrabber,
 |  | long * | lValue
 | ) |

int AC IC_SetExpRegVal | ( | HGRABBER | hGrabber,
 |  | long | lValue
 | ) |

int AC IC_EnableExpRegValAuto | ( | HGRABBER | hGrabber,
 |  | int | iOnOff
 | ) |

int AC IC_GetExpRegValAuto | ( | HGRABBER | hGrabber,
 |  | int * | iOnOff
 | ) |

int AC IC_IsExpAbsValAvailable ( HGRABBER hGrabber )

Functions for the absolute values interface of exposure.

int AC IC_GetExpAbsValRange | ( | HGRABBER | hGrabber,
 |  | float * | fMin,
 |  | float * | fMax
 | ) |

int AC IC_GetExpAbsVal | ( | HGRABBER | hGrabber,
 |  | float * | fValue
 | ) |

int AC IC_SetExpAbsVal | ( | HGRABBER | hGrabber,
 |  | float | fValue
 | ) |

int AC IC_GetColorEnhancement | ( | HGRABBER | hGrabber,
 |  | int * | OnOff
 | ) |

Gets the current value of Colorenhancement property Sample:

    int OnOFF
    IC_GetColorEnhancement(hGrabber, &OnOFF);
Parameters:
hGrabber Handle to a grabber object.
OnOff
  • 0 : Color enhancement is off
  • 1 : Color enhancement is on
Return values:
IC_SUCCESS | : Success
IC_NOT:AVAILABLE | : The property is not supported by the current device
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_SetColorEnhancement | ( | HGRABBER | hGrabber,
 |  | int | OnOff
 | ) |

Sets the value of Colorenhancement property Sample:

    int OnOFF = 1
    IC_GetColorEnhancement(hGrabber, OnOFF);
Parameters:
hGrabber Handle to a grabber object.
OnOff
  • 0 : Color enhancement is off
  • 1 : Color enhancement is on
Return values:
IC_SUCCESS | : Success
IC_NOT:AVAILABLE | : The property is not supported by the current device
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_SoftwareTrigger ( HGRABBER hGrabber )

Sends a software trigger to the camera. The camera must support external trigger. The external trigger has to be enabled previously

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | : Success
IC_NOT:AVAILABLE | : The property is not supported by the current device
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
@seealso IC_EnableTrigger

int AC IC_SetFrameRate | ( | HGRABBER | hGrabber,
 |  | float | FrameRate
 | ) |

Sets a new frame rate.

Parameters:
hGrabber | Handle to a grabber object.
FrameRate | The new frame rate.
Return values:
IC_SUCCESS | : Success
IC_NOT_AVAILABLE | : The property is not supported by the current device
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_NOT_IN_LIVEMODE | Frame rate can not set, while live video is shown. Stop Live video first!

float AC IC_GetFrameRate ( HGRABBER hGrabber )

Retrieves the current frame rate

Parameters:
hGrabber Handle to a grabber object.
Return values:
The current frame rate. If it is 0.0, then frame rates are not supported.

int AC IC_SetWhiteBalanceAuto | ( | HGRABBER | hGrabber,
 |  | int | iOnOff
 | ) |

int AC IC_SetWhiteBalanceRed | ( | HGRABBER | hGrabber,
 |  | long | Value
 | ) |

Sets the value for white balance red.

Parameters:
hGrabber | Handle to a grabber object.
Value | Value of the red white balance to be set
Return values:
IC_SUCCESS | : Success
IC_NO_HANDLE | : Invalid grabber handle
IC_NO_DEVICE | : No video capture device opened
IC_NOT_AVAILABLE | : The property is not supported by the current device

int AC IC_SetWhiteBalanceGreen | ( | HGRABBER | hGrabber,
 |  | long | Value
 | ) |

Sets the value for white balance green.

Parameters:
hGrabber | Handle to a grabber object.
Value | Value of the green white balance to be set
Return values:
IC_SUCCESS | : Success
IC_NO_HANDLE | : Invalid grabber handle
IC_NO_DEVICE | : No video capture device opened
IC_NOT_AVAILABLE | : The property is not supported by the current device

int AC IC_SetWhiteBalanceBlue | ( | HGRABBER | hGrabber,
 |  | long | Value
 | ) |

Sets the value for white balance blue.

Parameters:
hGrabber | Handle to a grabber object.
Value | Value of the blue white balance to be set
Return values:
IC_SUCCESS | : Success
IC_NO_HANDLE | : Invalid grabber handle
IC_NO_DEVICE | : No video capture device opened
IC_NOT_AVAILABLE | : The property is not supported by the current device

int AC IC_FocusOnePush ( HGRABBER hGrabber )

Performs the one push for Focus

Parameters:
hGrabber | Handle to a grabber object.
Value | Value of the blue white balance to be set
Return values:
IC_SUCCESS | : Success
IC_NO_HANDLE | : Invalid grabber handle
IC_NO_DEVICE | : No video capture device opened
IC_NOT_AVAILABLE | : The property is not supported by the current device

int AC IC_ShowInternalPropertyPage ( HGRABBER hGrabber )

Show the internal property page of the camera

int AC IC_ResetProperties ( HGRABBER hGrabber )

Resets all properties to their default values. If a property has automation, the automatic will be enabled. If the device supports external trigger, the external trigger will be disabled.

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_ResetUSBCam ( HGRABBER hGrabber )

Resets the driver. Do not use, for internl purposes only.

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_QueryPropertySet ( HGRABBER hGrabber )

This function queries the internal property set (KsPropertySet) of the driver. It allows an application to access all properties of a video capture devices using the enums and GUIDs from the header files fwcam1394propguid.h and fwcam1394props.h.

Parameters:
hGrabber Handle to a grabber object.
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_ERROR | The property could not have been retrieved

int AC IC_SetDefaultWindowPosition | ( | HGRABBER | hGrabber,
 |  | int | Default
 | ) |

Enables or disables the default window size lock of the video window.

Parameters:
hGrabber | Handle to a grabber object.
Default | 0 = disable, custome size can be set, 1 = enable, the standard size, which is video format, is used.
Return values:
IC_SUCCESS | Success
IC_ERROR | Setting of the values failed
IC_NO_PROPERTYSET | The property set was not retrieved or is not available.
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_SetWindowPosition | ( | HGRABBER | hGrabber,
 |  | int | PosX,
 |  | int | PosY,
 |  | int | Width,
 |  | int | Height
 | ) |

This function Sets the position and size of the video window.

Parameters:
hGrabber | Handle to a grabber object.
PosX | Specifies the x-coordinate of the upper left hand corner of the video window. It defaults to 0.
PosY | Specifies the y-coordinate of the upper left hand corner of the video window. It defaults to 0.
width | Specifies the width of the video window.
height | Specifies the height of the video window.
Return values:
IC_SUCCESS | Success
IC_ERROR | Setting of the values failed
IC_DEFAULT_WINDOW_SIZE_SET | The property set was not retrieved or is not available.
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened

int AC IC_IsPropertyAvailable | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element
 | ) |

Check, whether a property is available.. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is not checked.
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.
Simple call:
    if( IC_IsPropertyAvailable( hGrabber, "Brightness",NULL) == IC_SUCCESS )
    {
        printf("Brightness is supported\n");
    }
    else
    {
        printf("Brightness is not supported\n");
    }

Complex call for a special element:

    if( IC_IsPropertyAvailable( hGrabber, "Trigger","Software Trigger") == IC_SUCCESS )
    {
        printf("Software trigger is supported\n");
    }
    else
    {
        printf("Software trigger is not supported\n");
    }

int AC IC_GetPropertyValueRange | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | int * | Min,
 |  | int * | Max
 | ) |

This returns the range of a property. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Min | Receives the min value of the property
Max | Receives the max value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.
    HGRABBER hGrabber; // The handle of the grabber object.

    int Min;
    int Max;
    int Result = IC_ERROR;
    HGRABBER hGrabber;

    if( IC_InitLibrary(0) )
    {
        hGrabber = IC_CreateGrabber();
        IC_OpenVideoCaptureDevice(hGrabber, "DFx 31BG03.H");

        if( hGrabber )
        {
            Result = IC_GetPropertyValueRange(hGrabber,"Exposure","Auto Reference", &Min, &Max );

            if( Result == IC_SUCCESS )
                printf("Expsure Auto Reference Min %d, Max %d\n", Min, Max);

            Result = IC_GetPropertyValueRange(hGrabber,"Exposure",NULL, &Min, &Max );

            if( Result == IC_SUCCESS )
                printf("Exposure Value Min %d, Max %d\n", Min, Max);
    }
    IC_ReleaseGrabber( hGrabber );

int AC IC_GetPropertyValue | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | int * | Value
 | ) |

This returns the current value of a property. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Value | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_SetPropertyValue | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | int | Value
 | ) |

This sets a new value of a property. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Value | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_GetPropertyAbsoluteValueRange | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | float * | Min,
 |  | float * | Max
 | ) |

This returns the range of an absolute value property. Usually it is used for exposure. a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Min | Receives the min value of the property
Max | Receives the max value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_GetPropertyAbsoluteValue | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | float * | Value
 | ) |

This returns the current value of an absolute value property. Usually it is used for exposure. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Value | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_SetPropertyAbsoluteValue | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | float | Value
 | ) |

This sets a new value of an absolute value property. Usually it is used for exposure. a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Value".
Value | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_GetPropertySwitch | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | int * | On
 | ) |

This returns the current value of a switch property. Switch properties are usually used for enabling and disabling of automatics. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Auto".
On | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_SetPropertySwitch | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element,
 |  | int | On
 | ) |

This sets the value of a switch property. Switch properties are usually used for enabling and disabling of automatics. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. Gain, Exposure
Element | The type of the interface, e.g. Value, Auto. If NULL, it is "Auto".
On | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

int AC IC_PropertyOnePush | ( | HGRABBER | hGrabber,
 |  | char * | Property,
 |  | char * | Element
 | ) |

This executes the on push on a property. These properties are used for white balance one push or for software trigger. For a list of properties and elements use the VCDPropertyInspector of IC Imaging Control.

Parameters:
hGrabber | Handle to a grabber object.
Property | The name of the property, e.g. "Trigger"
Element | The type of the interface, e.g. "Software Trigger"
On | Receives the value of the property
Return values:
IC_SUCCESS | Success
IC_NO_HANDLE | Invalid grabber handle
IC_NO_DEVICE | No video capture device opened
IC_PROPERTY_ITEM_NOT_AVAILABLE | A requested property item is not available
IC_PROPERTY_ELEMENT_NOT_AVAILABLE | A requested element of a given property item is not available
IC_PROPERTY_ELEMENT_WRONG_INTERFACE | requested element has not the interface, which is needed.

Generated on Fri Jan 27 17:05:25 2012 for The Imaging Source Ansi Wrapper DLL by doxygen 1.2.14 written by Dimitri van Heesch, © 1997-2002


Annotated Index

The Imaging Source Ansi Wrapper DLL Data Structures

Here are the data structures with brief descriptions:
HGRABBER_t__
Generated on Fri Jan 27 17:05:25 2012 for The Imaging Source Ansi Wrapper DLL by doxygen 1.2.14 written by Dimitri van Heesch, © 1997-2002


HGRABBER_t__ Struct Reference

#include <tisgrabber.h>

Data Fields

int unused

Detailed Description

This is the handle of an grabber object. Please use the HGRABBER type to access this object.

Field Documentation

int HGRABBER_t__::unused

The documentation for this struct was generated from the following file:
  • tisgrabber.h


Compound Member Index

The Imaging Source Ansi Wrapper DLL Data Fields

Here is a list of all struct and union fields with links to the struct/union documentation for each field:
  • unused : HGRABBER_t__


File Member Index

The Imaging Source Ansi Wrapper DLL Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:
  • __HWND : tisgrabber.h
  • AC : tisgrabber.h
  • DEVICE_LOST_CALLBACK : tisgrabber.h
  • FRAME_READY_CALLBACK : tisgrabber.h
  • HGRABBER : tisgrabber.h
  • HGRABBER_t : tisgrabber.h
  • IC_BeginPaint() : tisgrabber.h
  • IC_CameraPropertyGetRange() : tisgrabber.h
  • IC_CloseLibrary() : tisgrabber.h
  • IC_CloseVideoCaptureDevice() : tisgrabber.h
  • IC_CreateGrabber() : tisgrabber.h
  • IC_DEFAULT_WINDOW_SIZE_SET : tisgrabber.h
  • IC_EnableAutoCameraProperty() : tisgrabber.h
  • IC_EnableAutoVideoProperty() : tisgrabber.h
  • IC_EnableExpRegValAuto() : tisgrabber.h
  • IC_EnableOverlay() : tisgrabber.h
  • IC_EnableTrigger() : tisgrabber.h
  • IC_EndPaint() : tisgrabber.h
  • IC_ERROR : tisgrabber.h
  • IC_FocusOnePush() : tisgrabber.h
  • IC_GetAutoCameraProperty() : tisgrabber.h
  • IC_GetAutoVideoProperty() : tisgrabber.h
  • IC_GetCameraProperty() : tisgrabber.h
  • IC_GetColorEnhancement() : tisgrabber.h
  • IC_GetDevice() : tisgrabber.h
  • IC_GetDeviceCount() : tisgrabber.h
  • IC_GetDeviceName() : tisgrabber.h
  • IC_GetDisplayName() : tisgrabber.h
  • IC_GetExpAbsVal() : tisgrabber.h
  • IC_GetExpAbsValRange() : tisgrabber.h
  • IC_GetExpRegVal() : tisgrabber.h
  • IC_GetExpRegValAuto() : tisgrabber.h
  • IC_GetExpRegValRange() : tisgrabber.h
  • IC_GetFormat() : tisgrabber.h
  • IC_GetFrameRate() : tisgrabber.h
  • IC_GetImageDescription() : tisgrabber.h
  • IC_GetImagePtr() : tisgrabber.h
  • IC_GetInputChannel() : tisgrabber.h
  • IC_GetInputChannelCount() : tisgrabber.h
  • IC_GetPropertyAbsoluteValue() : tisgrabber.h
  • IC_GetPropertyAbsoluteValueRange() : tisgrabber.h
  • IC_GetPropertySwitch() : tisgrabber.h
  • IC_GetPropertyValue() : tisgrabber.h
  • IC_GetPropertyValueRange() : tisgrabber.h
  • IC_GetSerialNumber() : tisgrabber.h
  • IC_GetTriggerModes() : tisgrabber.h
  • IC_GetUniqueName() : tisgrabber.h
  • IC_GetUniqueNamefromList() : tisgrabber.h
  • IC_GetVideoFormat() : tisgrabber.h
  • IC_GetVideoFormatCount() : tisgrabber.h
  • IC_GetVideoFormatHeight() : tisgrabber.h
  • IC_GetVideoFormatWidth() : tisgrabber.h
  • IC_GetVideoNorm() : tisgrabber.h
  • IC_GetVideoNormCount() : tisgrabber.h
  • IC_GetVideoProperty() : tisgrabber.h
  • IC_InitLibrary() : tisgrabber.h
  • IC_IsCameraPropertyAutoAvailable() : tisgrabber.h
  • IC_IsCameraPropertyAvailable() : tisgrabber.h
  • IC_IsDevValid() : tisgrabber.h
  • IC_IsExpAbsValAvailable() : tisgrabber.h
  • IC_IsPropertyAvailable() : tisgrabber.h
  • IC_IsTriggerAvailable() : tisgrabber.h
  • IC_IsVideoPropertyAutoAvailable() : tisgrabber.h
  • IC_IsVideoPropertyAvailable() : tisgrabber.h
  • IC_ListDevices() : tisgrabber.h
  • IC_ListVideoFormats() : tisgrabber.h
  • IC_LoadDeviceSettings() : tisgrabber.h
  • IC_LoadDeviceStateFromFile() : tisgrabber.h
  • IC_MsgBox() : tisgrabber.h
  • IC_NO_DEVICE : tisgrabber.h
  • IC_NO_HANDLE : tisgrabber.h
  • IC_NO_PROPERTYSET : tisgrabber.h
  • IC_NOT_AVAILABLE : tisgrabber.h
  • IC_NOT_IN_LIVEMODE : tisgrabber.h
  • IC_OpenDevByDisplayName() : tisgrabber.h
  • IC_OpenDevByUniqueName() : tisgrabber.h
  • IC_OpenDeviceBySettings() : tisgrabber.h
  • IC_OpenVideoCaptureDevice() : tisgrabber.h
  • IC_PrepareLive() : tisgrabber.h
  • IC_PROPERTY_ELEMENT_NOT_AVAILABLE : tisgrabber.h
  • IC_PROPERTY_ELEMENT_WRONG_INTERFACE : tisgrabber.h
  • IC_PROPERTY_ITEM_NOT_AVAILABLE : tisgrabber.h
  • IC_PropertyOnePush() : tisgrabber.h
  • IC_QueryPropertySet() : tisgrabber.h
  • IC_ReleaseGrabber() : tisgrabber.h
  • IC_ResetProperties() : tisgrabber.h
  • IC_ResetUSBCam() : tisgrabber.h
  • IC_SaveDeviceSettings() : tisgrabber.h
  • IC_SaveDeviceStateToFile() : tisgrabber.h
  • IC_SaveImage() : tisgrabber.h
  • IC_SetCallbacks() : tisgrabber.h
  • IC_SetCameraProperty() : tisgrabber.h
  • IC_SetColorEnhancement() : tisgrabber.h
  • IC_SetContinuousMode() : tisgrabber.h
  • IC_SetDefaultWindowPosition() : tisgrabber.h
  • IC_SetExpAbsVal() : tisgrabber.h
  • IC_SetExpRegVal() : tisgrabber.h
  • IC_SetFormat() : tisgrabber.h
  • IC_SetFrameRate() : tisgrabber.h
  • IC_SetFrameReadyCallback() : tisgrabber.h
  • IC_SetHWnd() : tisgrabber.h
  • IC_SetInputChannel() : tisgrabber.h
  • IC_SetPropertyAbsoluteValue() : tisgrabber.h
  • IC_SetPropertySwitch() : tisgrabber.h
  • IC_SetPropertyValue() : tisgrabber.h
  • IC_SetTriggerMode() : tisgrabber.h
  • IC_SetTriggerPolarity() : tisgrabber.h
  • IC_SetVideoFormat() : tisgrabber.h
  • IC_SetVideoNorm() : tisgrabber.h
  • IC_SetVideoProperty() : tisgrabber.h
  • IC_SetWhiteBalanceAuto() : tisgrabber.h
  • IC_SetWhiteBalanceBlue() : tisgrabber.h
  • IC_SetWhiteBalanceGreen() : tisgrabber.h
  • IC_SetWhiteBalanceRed() : tisgrabber.h
  • IC_SetWindowPosition() : tisgrabber.h
  • IC_ShowDeviceSelectionDialog() : tisgrabber.h
  • IC_ShowInternalPropertyPage() : tisgrabber.h
  • IC_ShowPropertyDialog() : tisgrabber.h
  • IC_SignalDetected() : tisgrabber.h
  • IC_SnapImage() : tisgrabber.h
  • IC_SoftwareTrigger() : tisgrabber.h
  • IC_StartLive() : tisgrabber.h
  • IC_StopLive() : tisgrabber.h
  • IC_SUCCESS : tisgrabber.h
  • IC_SuspendLive() : tisgrabber.h
  • IC_VideoPropertyGetRange() : tisgrabber.h
  • NOHWNDDEFINED : tisgrabber.h